Problems with Cadence on Solaris 9

Discussion in 'Cadence' started by Hristo Brachkov, Aug 20, 2003.

  1. Hello,

    I have the following problem:

    I was trying to install Cadence 446.100.80 on Solaris 9. The installations
    seemed to be OK, however when I try to start some design kit (I tried this
    with 2 different ones) Cadence behaves rather strange - If I try to use
    File -> Open it is not possible to be done although I click on the cell and
    it seems selected, but it does not appear in the field of the one to be
    opened. I can open a cell only using Library Manager, but in that case I get
    a lot of complains and the cell cannot be edited, like in a case when the
    license server is not working. I tried to check the licenses, however
    SURPRISE!!! I cannot click the buttons. The text "Check In" and "Check Out"
    is there, but just as some text.

    Two more clarifications - The license server is HP machine and this is the
    first time I'm trying to install Cadence on Solaris. I've never had those
    problems when installing on HP.

    On the CDs it's written that they are for Sun/SPARK Solaris 2.X and as far
    as I know Solaris 9 corresponds to 5.9. Could this be a problem?

    Does somebody know what might be the real problem?


    Hristo Brachkov, Aug 20, 2003
  2. HI,

    Solaris 9 is a boundle of UNIX(SunOS 5.9) and Xwindows and more stuff.

    Som SUN history.

    Solaris 2.5 uses SunOS 5.5(UNIX OS)
    Solaris 2.6 uses SunOS 5.6
    Solaris 2.7 never existed, the marketing guys the decided to change name
    to Solaris 7
    Solaris 8 is SunOS 5.8(UNIX)

    So what CDS means is that 2.x that is all Solaris version, from 2.0 to
    2.5, but Solaris 7,8,9 could be a problem is CDS has just been not clear
    enough on the CD.

    How old is the software distribution, Years or fresh?

    What is 446.100.80 actually, is the real CDS name?

    Michael Laajanen, Aug 24, 2003
  3. Indeed, it looks exactly like a problem I had on a linux machine that
    was set with a european locale.
    I modified the startup scripts like this:

    cd /cds/tools/dfII/bin ; file * |grep 'script text'|cut -d:
    -f1|xargs grep -l 'inst_dir=`cds_root $0`' |xargs replace
    'inst_dir=`cds_root $0`' 'inst_dir=`cds_root $0` ; [ ! -z "$LANG" ] &&
    LANG=C' --

    ( run this oneliner only once !)
    it makes use of the "replace" command that is delivered with mySQL, but
    an "ed" script can do the same job.

    It would be nice that cadence apps support internationalisation, or at
    least don t break when the unix settings are non-american.
    eda support guy, Sep 1, 2003
  4. Thanks, Andrew!

    Now seems everything is working just fine!

    Hristo Brachkov, Sep 2, 2003
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.