Plot - Scale to fit in Lisp command line not working?

Discussion in 'AutoCAD' started by smcatee, Jul 23, 2004.

  1. smcatee

    smcatee Guest

    I am trying to make my lisp program plot a layout with "Scale to Fit" enter on the command line, set from a variable, and it is not accepting it.

    If I run this line:
    (setq PLOTSCALE "Fit")

    and then run this command sequence:
    (command "-PLOT" "Y" "" "L1-5100.pc3" "A3" "M" "L" "N" "L" PLOTSCALE "0,0" "Y" "HPA-STD.ctb" "Y" "Y" "N" "N" "N" "N" "Y")

    The print seems to come out at 1:1. I have also tried:
    (setq PLOTSCALE "F")

    Any help would be greatly appreciated.

    smcatee, Jul 23, 2004
  2. smcatee

    dblaha Guest

    It looks like it should work. What are your llimits set to? Have you tried the exact same settings in the PLOT dialog to see if you get the same results?
    dblaha, Jul 23, 2004
  3. smcatee

    smcatee Guest

    That's the problem...I know it looks like it should work but it doesn't.

    I'm not sure what limits have to do with it but there are set to
    Lower Left: 0,0
    Upper Right: 841,594

    Back to you,

    smcatee, Jul 23, 2004
  4. smcatee

    dblaha Guest

    The limits matter because the settings you posted have the plot area set to your limits. (the "L" right before PLOTSCALE). Every time you plot with those settings, everything within your limits will get fit onto the page.

    Again, try manually entering these exact settings into your plot dialog to see if you get the same results. If you do, then the routine is fine and you just need to change your settings if you want the plot to look different.
    dblaha, Jul 23, 2004
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.