Pin creation and displaying pin name using SKILL

Discussion in 'Cadence' started by Manoj Venkatasubbu, Sep 21, 2010.

  1. Hi,

    I have a skill routine that creates pins in the layout. I followed the
    same procedure mentioned in

    http://groups.google.com/group/comp...5e1bec6?lnk=gst&q=create+pin#d70eb916e5e1bec6

    The pins are being created but I run into a problem at the parasitic
    extraction stage. The extraction engine is not able to identify these
    pins because there is no label attached to these pins.
    When I manually create a pin I check the option 'Display Pin Name'
    option and this creates a label attached to the pin and this pin is
    visible in the extracted netlist.

    I created a label (dbCreateLabel) and tried to attach it to the pin
    using leAttachFig, but this doesn't work.

    Any help will be much appreciated.


    Additional info:
    I noticed that in a manually created pin, say pin1,
    pin1~>children~>owner and pin1~>children~>associate is not nil, but
    for pins created from the routine the owner and associate fields are
    nil. Although leAttachFig is creating a parent-child link between the
    pin and the label it leaves the owner and associate fields empty.
     
    Manoj Venkatasubbu, Sep 21, 2010
    #1
    1. Advertisements

  2. Manoj Venkatasubbu

    rick Guest

    Are you using Assura? Having the text "attached" to the pin should
    not matter.
    The extracter will look at either or both depending on your rule file:

    1) pin connectivity. Query the pin and see if it has connectivity
    which matches the pin name
    2) text on the the correct layer and the text origin must be touching
    the metal that you are connecting to.

    You can to a pre-RCX pin check by looking in the <run_name>.erc and to
    see if the pin is attached or floating
    or not listed.

    Rick
     
    rick, Sep 27, 2010
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.