Newbie Alert: Problems installing IC5033 on Scientific Linux 5.1

Discussion in 'Cadence' started by bogdan.mocanu21, Sep 1, 2008.

  1. Hi there, guys
    I'm trying to figure out my first Cadence installation ... but it
    seems I kinda need your help...so here it goes:

    The installation part from the terminal went great ... but I have
    these problems setting up the configuraton files.

    I configured the Bind key by copying all the files from <install_dir>/
    tools/dfII/sample/local to <install_dir>/tools/dfII/local, and
    renamed the cdsinit to .cdsinit.

    So far so good.

    I edited .bashrc in the /home/user/ folder and it looks like this:
    Code:
    export CDS_ROOT=/home/bogdan/IC5033/
    export CDS_INST_DIR=$CDS_ROOT
    export CDS_INSTALL_DIR=$CDS_ROOT/tools/dfII

    export CDSDIR=$CDS_ROOT/tools
    export CDS_Netlisting_Mode=Analog

    export MOZILLA_HOME=/usr/bin/netscape
    export XKEYSYMDB=$CDS_ROOT/share/cdssetup/tdmX11/XKeysymDB
    export XNLSPATH=$CDS_ROOT/share/cdssetup/tdmX11/nls
    export CDS_WAVESCAN_JRE_DIR=$CDS_ROOT/tools/jre1.41

    export CDS_LIC_FILE=$CDS_ROOT/share/license/cadence_license_full.dat
    export LM_LICENSE_FILE=$CDS_ROOT/share/license/
    cadence_license_full.dat
    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$CDS_ROOT/tools/lib:
    $CDS_INSTALL_DIR/lib

    PATH=$PATH:$CDSDIR/bin:$CDSDIR/dfII/bin:$CDSDIR/SKILL06.00/context:
    $CDSDIR/SKILL06.10/context:$CDSDIR/dracula/bin
    # PATH=$PATH:$MMSIM_ROOT/tools/bin:$MMSIM_ROOT/tools/spectre/bin:
    $CDS_ROOT/tools/bin:$CDS_ROOT/tools/dfII/bin:/usr/sbin
    PATH=$CDS_ROOT/tools/bin:$CDS_INSTALL_DIR/bin:$CDS_ROOT/tools/spectre/
    bin
    PATH=$PATH:$CDS_ROOT/tools/bin:$CDS_INSTALL_DIR/bin:$CDS_ROOT/tools/
    spectre/bin
    PATH=$PATH:/bin:/usr/local/bin:/usr/bin:/usr/ucb:/etc:/usr/openwin/
    bin:/usr/X11R6/bin
    export PATH
    #----------------------------------------------------------------------------

    # .bashrc

    # Source global definitions
    if [ -f /etc/bashrc ]; then
    . /etc/bashrc
    fi

    # User specific aliases and functions


    I copied the license.dat to /home/bogdan/IC5033/share/license/
    cadence_license_full.dat (as the .bashrc file says). Was there
    anything else to do because after restarting the konsole and when I
    try to run icfb& it says:

    Code:
    [1] 4168
    [bogdan(at)localhost ~]$ /home/bogdan/IC5033/tools/dfII/bin/icfb.exe:
    relocation error: /home/bogdan/IC5033/tools/dfII/bin/icfb.exe: symbol
    errno, version GLIBC_2.0 not defined in file libc.so.6 with link time
    reference

    [1]+ Exit 127 icfb


    Thanks in advance.
     
    bogdan.mocanu21, Sep 1, 2008
    #1
    1. Advertisements

  2. bogdan.mocanu21

    Riad KACED Guest

    Riad KACED, Sep 1, 2008
    #2
    1. Advertisements

  3. Well, I've added in the .bashrc file the following line: export
    LD_ASSUME_KERNEL="2.6.18" (adjusted for my case).
    and terminal still gives the same message error when I type icfb. Any
    other suggestions ? I really need this installed because I have this
    important project coming up ...
     
    bogdan.mocanu21, Sep 2, 2008
    #3
  4. Riad KACED wrote, on 09/01/08 22:30:
    Your Cadence Support Engineer would tell you that neither IC5033 or Scientific
    Linux 5.1 are supported. That said, I suspect that Scientific Linux is broadly
    compatible with RHEL 5.1 from a quick glance at the Scientific Linux web site.
    You'd probably be able to run IC5141 (recent ISRs) or IC61X on this, although it
    wouldn't be supported. IC5033 hasn't been supported for some considerable time
    though.

    Regards,

    Andrew.
     
    Andrew Beckett, Sep 2, 2008
    #4


  5. I've added the following line to the .bashrc file : export
    LD_ASSUME_KERNEL="2.6.18" (adjusted for my case)
    and I receive the same message error (mentioned in my last post) when
    I type icfb in terminal. Any other suggestions ?
    I really need this installed ... ( any ideas are welcomed ) because I
    have this important project coming up.
    At this point do I have to install some other linux distro ?

    Bogdan M.
     
    bogdan.mocanu21, Sep 2, 2008
    #5
  6. I suspect your kernel is actually 2.6.18, so there's no point setting
    LD_ASSUME_KERNEL to whatever your kernel actually is - the whole point of the
    environment variable is to tell the linker that it should assume you're using
    an older kernel.

    As I said before, I wouldn't necessarily expect this to work. I have RHEL 5.1
    on my laptop, and tried IC5033 (the last ISR there was), and got the same
    error.

    Setting LD_ASSUME_KERNEL to 2.4.1 gives a different error.

    I think you're probably doomed. As I said in my previous post, try a more
    recent (and supported) version of IC if you're going to use this compute platform.

    Regards,

    Andrew.
     
    Andrew Beckett, Sep 2, 2008
    #6
  7. - Yes, I've tried setting LD_ASSUME_KERNEL to an older version , but
    it gave other errors ... even ls wasn't working ...
    So I'm doomed, huh ? I only have this installation kit : IC5033 ... so
    I said that I have to deal with it and to deal with the installation.
    I really don't know any other download sources. Does anybody know
    any ?
    - I read a lot about compatible Linux Distros and I got to the
    conclusion that using Scientific Linux 5.1 or CentOs 5.1 is the same
    as using RHEL.
    First I tried older linux distros like: Redhat 8 or 9 but I couldn't
    even start the installation because they didn't even have support for
    sATA hard-drives.


    Bogdan M.
     
    bogdan.mocanu21, Sep 2, 2008
    #7
  8. Would it be better if I install IC5141 ? The fact that I'm using
    another version of IC must not influence the fact that I'm working
    with a certain technology, right ?
     
    bogdan.mocanu21, Sep 4, 2008
    #8
  9. Bogdan,

    I can run IC5033 on RHEL4. RH8 or RH9 are pretty old. RHEL4 may well support the
    drivers you need for your hardware?

    IC5141 _might_ be OK. It depends on the design kit you're using. Sometimes they
    have coding to check the version number and disallow it if using a newer
    version. Usually there is little technical reason why you couldn't use it, but
    because it hasn't been validated by the design kit provider, they disallow it.

    Regards,

    Andrew.
     
    Andrew Beckett, Sep 5, 2008
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.