Hatch spacing too dense, or dash size too small

Discussion in 'AutoCAD' started by edwa8511, Mar 1, 2004.

  1. edwa8511

    edwa8511 Guest

    "Hatch spacing too dense, or dash size too small" This is what I get when I try to hatch a large polygon in my drawing. I need a smaller scale on my hatch than AutoCAD will allow. Does anyone know how to change a setting that will let me hatch to smaller scales?
     
    edwa8511, Mar 1, 2004
    #1
    1. Advertisements

  2. edwa8511

    RichardG Guest

    (defun c:mhatch ()

    (setenv "MaxHatch" "1000000")

    (prompt "\nHatch Density is set to a big number...Retry your Hatch scale")

    (princ)

    )

    Try this

    Richard

    I try to hatch a large polygon in my drawing. I need a smaller scale on my
    hatch than AutoCAD will allow. Does anyone know how to change a setting
    that will let me hatch to smaller scales?
     
    RichardG, Mar 1, 2004
    #2
    1. Advertisements

  3. edwa8511

    Gordon Price Guest

    I try to hatch a large polygon in my drawing. I need a smaller scale on my
    hatch than AutoCAD will allow. Does anyone know how to change a setting
    that will let me hatch to smaller scales?

    This bit o lisp bumps the MaxHatch var by 10,000 each time you run it. I
    prefer this over a single increased value, as it lets you bump a little till
    it works.

    Gordon

    (defun C:MHU () ; Increment MaxHatch Environment Variable
    (setenv "MaxHatch" (itoa (+ (atoi (getenv "MaxHatch")) 10000)))
    (prompt (strcat "MaxHatch set to " (getenv "MaxHatch")))
    (princ)
    )
     
    Gordon Price, Mar 2, 2004
    #3
  4. edwa8511

    OLD-CADaver Guest

    Gordon, why not just bump it to 1000000 once and be done?
     
    OLD-CADaver, Mar 2, 2004
    #4
  5. edwa8511

    Gordon Price Guest

    My understanding is that the var actually allocates ram, so using a bigger
    number than needed wastes ram. Probably a non issue really, but with an easy
    way to bump I just leave it that way. Personally, I wish AutoCAD would give
    the warning, then offer a button that just does the change, setting the var
    to 10% more than needed. The fact that this has to be done 'manually' is
    just lame. Same is true for the layer dialog sorting. It should just bump
    MaxSort as needed, with a CAD manager controlled warning level and ceiling,
    but beyond that just handle it.
    Oh well.

    Gordon
     
    Gordon Price, Mar 2, 2004
    #5
  6. edwa8511

    OLD-CADaver Guest

    Oh, okay, just curious. Thanks.
     
    OLD-CADaver, Mar 2, 2004
    #6
  7. edwa8511

    Gordon Price Guest

    I take it you have never run into any issues with just cranking it up? The
    other bummer is this is not a DWG based var. It would be nice to set the
    value in templates, based on the kind of drawing. Elevation base files get a
    high MaxHatch, sheet files get a low one, that kind of thing.

    Gordon
     
    Gordon Price, Mar 2, 2004
    #7
  8. edwa8511

    OLD-CADaver Guest

    We crank the ram up every chance we get, most are running 2G, with the smallest 1G.

    We set;
    (setenv "MaxHatch" "100000")
    (setenv "MaxArray" "50000")

    in the startup lisp, and as yet haven't had any problems. But then again we don't use small hatches either, AR-CONC is about as fine as it gets.
     
    OLD-CADaver, Mar 2, 2004
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.