Continuous CPU Anomoly

Discussion in 'SolidWorks' started by Jeff Norfolk, Aug 7, 2003.

  1. Jeff Norfolk

    Jeff Norfolk Guest

    Did anyone ever find a solution to this? We still experience the task
    manager reporting CPU usage at 10-25% during large assembly drawing
    saves and have tried a lot of things to no avail.
     
    Jeff Norfolk, Aug 7, 2003
    #1
    1. Advertisements

  2. Jeff Norfolk

    Todd Guest

    Jeff,

    What is the problem with the CPU usage?
     
    Todd, Aug 7, 2003
    #2
    1. Advertisements

  3. Jeff Norfolk

    Todd Guest

    If it is saving, why would you expect it to be at 100%? Saving is
    disk-writing or writing to the network which is much more of a speed thing
    then the processor running.

    I would be much more concerned with network speeds then CPU usage.
     
    Todd, Aug 7, 2003
    #3
  4. Jeff Norfolk

    Jeff Norfolk Guest

    Todd,

    I pulled an old thread regarding this. I couldn't reply to it, I guess
    cause it was older than 6 months, so those not using google won't see
    it. I didn't really think of that before now. This is obvious, but
    simply search on thru google to find the old 'Continuous CPU Anomoly'
    thread.
     
    Jeff Norfolk, Aug 8, 2003
    #4
  5. Jeff Norfolk

    Todd Guest

    Jeff,

    After reading through that thread, I think you are talking about something
    different completely. What that thread is talking about is simply starting
    SolidWorks, starting any new part/assy/or drawing and then checking the task
    manager. What their problem is, is that the task manager is reporting high
    CPU usage when doing nothing. Basically sitting idle.

    From what I gather, your question refers to CPU usage while saving, which
    sounds to me to be perfectly normal; yet a different topic altogether then
    what they are talking about.

    Let me know if I misunderstood your question.

    Todd
     
    Todd, Aug 8, 2003
    #5
  6. Jeff Norfolk

    Guest Guest

    Hi Jeff,

    I think I was the one that started the thread way back. I finally found that the culprit was my hotkey file (user.cus).
    Our IT guy uninstalled SWX and stripped the registry. He reinstalled SWX and I fired it up. The task manager reported
    between 0-3% activity. I then proceeded to set-up all of my custom crap and when I started SWX the second time I was
    back to 28-35% cpu usage doing nothing. I then removed the custom stuff and added it one by one. It turned out to be the
    ..cus file. I think I've carried that same file release to release since I've owned SWX (95 or 96 I think). After
    recreating my hotkey file from scratch, it's been back to normal.

    Ken Bosch
     
    Guest, Aug 11, 2003
    #6
  7. This is VERY interesting. Has anyone else seen this? We have also carried
    our.CUS file forward for a while and I wouldn't have ever thought of the
    need to recreate it.

    WT

    that the culprit was my hotkey file (user.cus).
    and I fired it up. The task manager reported
    and when I started SWX the second time I was
    and added it one by one. It turned out to be the
    I've owned SWX (95 or 96 I think). After
     
    Wayne Tiffany, Aug 11, 2003
    #7
  8. Jeff Norfolk

    Jeff Norfolk Guest

    Interesting. While I've never customized hotkeys, I think I might have
    an idea as to what my issue is.

    Recently I copied my files to my hard drive to work from. I noticed a
    huge increase in speed when loading assemblies and saving them. I've
    come to the conclusion that when trying to save to the network the
    connection is so slow that the 3GHz CPU doesn't max out because it's
    constantly waiting for the network lag to catch up. That's the only
    logic I can come up with because for the most part, the CPU is at 100%
    when saving to my local drive.
     
    Jeff Norfolk, Aug 12, 2003
    #8
  9. Jeff Norfolk

    Guest Guest

    Wayne,

    I can't explain what was going on there. I do remember that back in maybe SWX 97 or 99 quite a few of my old hotkeys
    vanished from the list of available commands in the command list. Even though they were not shown anymore I still got
    the error saying that key is already used (or whatever it was). The hotkeys still worked as they were intended.
    My only guess is that some obscure hotkey was activated in 2002-2003 that made some command constantly activated,
    causing the constant CPU usage.

    Ken B.

     
    Guest, Aug 12, 2003
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.