Cadence CAD tools on OpenSolaris

Discussion in 'Cadence' started by Bluebook, Aug 12, 2010.

  1. Bluebook

    Bluebook Guest

    Hello,

    I am trying to install Cadence IC610 (IC-614 06.14.506 Solaris 10)
    suite on OpenSolaris 2009.6 version.

    It seems that all the installation and configuration process using
    Installscape are finished without problem,
    but I encounter an error message like the following when I try to
    launch virtuoso design environment.

    virtuoso: ERROR: The command /tools/cadence/IC610/share/oa/bin/
    sysname returned an error status:
    unknown
    virtuoso: INFO: Note that OpenAccess (OA) requires running the
    Configure phase.
    virtuoso: See the "OpenAccess Installation and Configuration
    Guide" before
    virtuoso: you complete the configuration step. This manual is
    included with
    virtuoso: the Cadence product documentation.

    [1] Exit 1 virtuoso

    First of all, can I run IC610 on OpenSolaris machine? Is IC610
    Solaris10 (x86) version compatible with OpenSolaris? I tried this way
    since OpenSolaris is mostly compatible with Solaris 10, so I wanted to
    give it a shot.

    If they are compatible, does anyone have any suggestion to solve this
    error?

    Thank you in advance.
     
    Bluebook, Aug 12, 2010
    #1
    1. Advertisements

  2. Bluebook wrote, on 08/12/10 00:40:
    See my reply to your same question at

    http://www.cadence.com/Community/forums/p/16495/896710.aspx#896710

    Regards,

    Andrew.
     
    Andrew Beckett, Aug 12, 2010
    #2
    1. Advertisements

  3. Bluebook

    jayl-news Guest

    Ah, you've got those Oracle OS licensing blues, huh?
    Well, first, let's actually read the error message, right?

    sysname is a utility that the Virtuoso wrappers use to figure out what
    platform they're on; what OS version, what hardware type, etc. It
    runs
    uname w/various options, it snoops installation status files in /etc,
    stuff
    like that. It's just a shell script.

    In your case, you want it to return something like "sunos_510_x86",
    but it's returning "unknown" because one or more of the clues it's
    looking for aren't there. You could try to fix that, but there's a
    comment
    in the script that sure makes it look like you want to do something
    like
    this:

    export OA_UNSUPPORTED_PLAT=sunos_510_x86 (bash)
    setenv OA_UNSUPPORTED_PLAT sunos_510_x86 (tcsh)

    ....and try again. Or just run Linux, which would have the advantage
    of being supported (both by the OS supplier and by CDNS)!

    -Jay-
     
    jayl-news, Aug 12, 2010
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.